看见LD出了11.12.1版本,恰好觉得现在的LD有点不太好用了,主要是前几天安装conky然后卸载之留下的后遗症让我觉得很窝火(明明都卸载了conky,开机的时候竟然还能显示出来,真的很神奇)所以打算更新LD来看看是否能解决这个问题。所以就按照官网的做法来升级了,到最后却提示以下信息,显示升级错误。

错误 http://packages.linuxdeepin.com/deepin/ oneiric-updates/main bcmwl-kernel-source i386 5.100.82.38+bdcom-0ubuntu5~oneiric
404 Not Found
无法下载 http://packages.linuxdeepin.com/deepin/pool/main/b/bcmwl/bcmwl-kernel-source_5.100.82.38+bdcom-0ubuntu5~oneiric_i386.deb 404 Not Found

后来看了一下,显示404错误,估计大家心里都有数了。后来去论坛看了一下,不止我一个人出现这种情况,而LD的官网博客的管理员回复关于这个问题的时候是说正在修复,随后我又在几个群问了一下,有升级成功的也有失败的,失败的那位也是我和一样的问题,不知道是什么缘故,用软件管理中心也不能升级,真的很奇怪。

今天中午,有位群里的朋友看见我的留言之后答应晚上我还升级不了的话,再联系他,今晚没时间了就没去那个群,刚才打开那个群看历史消息的时候就看见了他发的信息,据说是可以升级的方法。以下是他的原话。。

apt-get dselect-upgrade --fix-missing是排除不能找到的软件进行升级,因为deepin好像会在某个软件找不到时全都不能升级

现在方法出来了,是否能升级成功我也不太清楚,现在先把这个方法放在这里,等我明天上网先再试试看吧,假如能升级的话,我再在博客上和大家说一下。很晚了,先休息了。。。