昨晚在开源社区看见有升级WordPress 3.4的文章刊出,就顺便去后台看了一下,果断在后台有了WordPress 3.4的更新提示,想想以前升级WordPress都没问题,这次绝对没问题的。但是事情往往就和绝对的事情相反,点击升级之后出现错误,后来点击返回首页发现已经进不去了,只有几行代码提示错误信息。

 Fatal error: Cannot redeclare wp_embed_handler_youku() in /home/makiller/public_html/wp-content/themes/loper/functions/shortcode.php on line 44

在群里问了一下,有人说是那个代码有重复,但是也说不出个所以然,代码这块我又看不懂,所以只能干着急。老谢给我指了一条明路,就是去老薛那提交支持单,让客服恢复以前的备份文件(整个CP文件夹)。单子提交上去之后,老薛的客服给了我一个提示,就是用老版本的WordPress来覆盖,试试看行不行。

登陆FTP后,上传WordPress老版本,然后在CP面板的文件管理器解压,然后覆盖进去,再上传原来备份的配置文件,重新刷新之后,首页顺利登陆。至此,问题解决。看提示的信息,感觉是loper的主题文件出了问题,具体是怎么样的,我也搞不清楚,总之问题解决,我也放下心了。